FAQ

Technical Help
Why are some PDFs displayed incorrectly?
Why do I get an error message when I open the Format Manager or try to use a format?
I can't find the user Library folder. Where is it?
Where is my reference library on the hard drive?
Where is the User Guide? Where are the tutorials?
How do I upgrade from one version of Bookends to another?
When I double click on the .dmg downloaded from Sonny Software, it doesn't open in the
Finder. Where is it?
Can I scan Word files that have EndNote citations?
How do I import references from other reference management apps?
Bookends isn’t working properly. What do I do?
Bookends is crashing even after I create a new database.
Why isn't scanning/inserting a citation in a Word document working?
How do I merge two libraries?
Why are text styles (i.e. italics, bold) not showing in my formatted references?
Why aren't PDFs added to the watch folder when Bookends isn't running imported?
How do I get a format or import filter to show up in the corresponding pop-up menus?
Where can I get a format for a particular source?
License/Purchase Information
Should I buy Bookends from Sonny Software or the Mac App Store?
I’d like to buy a license for the people in my group/department/institution. How much will it
cost?
I own Bookends—where can I find my registration (serial) number so I can upgrade at the
discounted price?
What methods of payment are accepted?
Can I install Bookends on both my desktop and laptop computers with one license?
Technical Help
Why are some PDFs displayed incorrectly?
There are bugs in PDFKit for macOS that can cause cosmetic artifacts in the display of large PDFs when
they are zoomed. If you encounter this, you can make the PDF render properly by changing the display to
"Actual Size", or use the "Single Page" or "Two Pages" option (as opposed to "Single Page Continuous"
or "Two Pages Continuous").
Why do I get an error message when I open the Format Manager or try to use a format?
One source of such errors is the presence of virus protection software. In particular, Intego Virus
Protection and Trend Micro have been reported to cause these errors. If you experience these, try
disabling Intego Virus Protection or Trend Micro (or whatever virus protection software you are running)
and see if the problem has been resolved. Another way to tell if virus protection software (or any other
process) is interfering with Bookends is to reboot in Safe mode (Shift key held down). If the problem
resolves, it's almost certainly do to some third party application or utility.
I can't find the user Library folder. Where is it?
In macOS the user Library folder is hidden by default. To access it, hold down the Option key (the Shift
key in macOS 10.12) and use the Finder menu Go -> Library. This will take you to
~/Library
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and you can follow the trail to
~/Library/Application Support/Bookends/
In Bookends 12, there is a menu option that will take you directly to the Bookends folder in Application
Support: Help -> Show Bookends Folder in Finder.
There you access to various Bookends support files if you ever need them, such as your formats, filters,
and Bookends preferences.
Where is my reference library on the hard drive?
When you create a new library, it is given a name and saved to disk using the standard Save dialog. The
default location is in your user Library folder
~/Library/Application Support/Bookends/
(remember that in Lion or later you must access your Library folder by holding down the Option key and
selecting the Go menu in the Finder).
Note that you can always see the full path to your reference library by pressing the Command key and
clicking on the file proxy icon in the library window title bar.
You can also get to the Bookends folder via the Bookends Help menu: Show Bookends Folder in Finder
Where is the User Guide? Where are the tutorials?
The User Guide, tutorials (pdf and video), and Read Me (version release notes) are available from the
Bookends Help menu.
How do I upgrade from one version of Bookends to another?
That depends on which version of Bookends you are upgrading from. A complete list of possible upgrade
avenues, with step-by-step instructions, is provided in the Read Me file in the Bookends Help menu.
When I double click on the .dmg downloaded from Sonny Software, it doesn't open in the Finder.
Where is it?
If you are using OS X 10.7 (Lion) or later, the dmg may not open as a separate window. Instead, look for it
in the Finder window, left pane, under Devices.
Can I scan Word files that have EndNote citations?
Usually. Follow these steps:
1) The key is to make sure that the EndNote record number in the citation matches the Bookends unique
ID for that reference. To do this, export your EndNote library as XML (requires EndNote 7 or later). Import
this into a fresh Bookends library and the EndNote record numbers will now be Bookends unique ID
numbers.
2) Open your document in Microsoft Word and use the EndNote unformat command if the citations were
entered with Cite While You Write. All citations should now be visible in their temporary form (for example,
surrounded by curly brackets).
3) Scan the document with Bookends (make sure that the citation delimiters, such as curly brackets, as
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set in Bookends Preferences are the same as those used by EndNote).
How do I import references from other reference management apps?
You can export and then import references, often with links to PDFs intact, from applications such as
EndNote, Papers, Sente, Zotero, Reference Manager, and Procite. Here are specific instructions.
Bookends isn’t working properly. What do I do?
Damage to your Bookends library can have unpredictable results. If you are having problems that cannot
be reproduced in a fresh Bookends library, it is likely that this is the cause. In this case, the first thing you
should do is to rebuild the library (File -> Library Maintenance -> Rebuild). If the problem persists, try to
repair your database (File -> Library Maintenance > Repair). If the problem has still not been resolved,
contact us for technical support.
Bookends is crashing even after I create a new database.
A damaged format may be the culprit. If so, changing your default format to one that we supply should fix
the problem. If it does, and the damaged format is one of ours, you can download a fresh copy from our
ftp server (ftp://www.sonnysoftware.com/pub).
Another possibility is that the problem is with Bookends preferences. If it is, this will help: go to the folder
~/Library/Application Support/Bookends/ and find the file called "Bookends XX Preferences" (where XX is
the version number, such as 12). Move that file to the desktop, and relaunch Bookends. You will be asked
for your registration number. Note: you will have to reset any preferences that you changed from the
defaults.
Note: The user Library is not directly accessible from the Finder in Mac OS X 10.7 or later. To access it,
hold down the Option key and use the menu Go -> Library in the Finder.
Why isn't scanning/inserting a citation in a Word document working?
Bookends exchanges information with Word via AppleEvents. There is a bug in Word that sometimes
causes it to stop responding to the "paste" AppleEvent, and after a scan or Copy Citation Word comes to
the front but the document's text is unchanged (although selected), and no bibliography was added. The
immediate solution is to perform a Paste Special yourself: Edit -> Paste Special -> Formatted Text (RTF).
The longer term solution is to either relaunch Word (which sometimes works) or reboot your Mac (which
usually seems to work).
Another possibility is that "Proofreading Scan" was checked in the scan dialog. Proofreading scans help
you manage temporary citations, they do not replace temporary citations with final citations, and will not
generate a bibliography. The User Guide has more information about Proofreading Scans.
How do I merge two libraries?
There are two ways to do this: (1) Mark all your references, use File -> Export References (Hits) to export
them as a "Bookends" file, and then import this file into the destination library, or (2) drag the references
from one library window and drop them on another. If you think there may be duplicate references, after
the merge choose the menu item Refs -> Remove Duplicates.
Why are text styles (i.e. italics, bold) not showing in my formatted references?
Check Preferences -> Scan & Bib or Biblio -> Bibliography and make sure the output is set to Styled Text.
If it is, then check the bibliography font you are using (the default is in Preferences), and the font used in a
reference that is not displaying styled text. Not all fonts have an italic face (Lucida Grande, for example),
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and in that case only plain text will be output.
Why aren't PDFs added to the watch folder when Bookends isn't running imported?
When a file is dropped into the watch folder, the Finder records the time and sends a notification to
Bookends. Sometimes the folder's metadata becomes corrupted and the time isn't saved and Bookends
is not notified when next launched. To correct this, create a new watch folder and point Bookends to it
(File -> Import From Watch Folder -> Configure). Add the PDFs to the new folder and they will be
imported, as will subsequently added PDFs, even if Bookends was not running when they were placed in
the watch folder.
How do I get a format or import filter to show up in the corresponding pop-up menus?
You must enable the format or import filter by checking it in either the Formats Manager or the Import
Filters Manager, respectively.
Where can I get a format for a particular source?
You can create your own formats by selecting one in the Formats Manager that is similar to the one you
want and clicking on the Add button (use Biblio -> Create Format Catalog to see examples of all the
formats shipped with Bookends). Create an appropriate name for the new format and make whatever
changes are necessary. Details on format design are available in the User Guide. Alternatively, you can
ask other Bookends users if they have created such a format and will share it on the Bookends User
Forum. If you have altered a format we supply and want to obtain the original, you can download it from
our ftp site: ftp://ftp.sonnysoftware.com/pub/Formats/ (sign in as Guest).
License/Purchase Information
Should I buy Bookends from Sonny Software or the Mac App Store?
Buying from Sonny Software has these advantages: (1) you may be eligible for discount pricing, (2)
updates will be available sooner, (3) fixes for small bugs that may aﬀect you can be made available
immediately in silent updates, (4) some features may be modified or removed in the Mac App Store
version due to restrictions enforced by Apple, and (5) Bookends will automatically notify you when
updates are available (an example of a feature that was removed from the Mac App Store version).
Buying from the Mac App Store has these advantages: (1) the initial download and future updates require
only one click, and you may prefer obtaining updates for many or all of your apps from a single source,
and (2) your order will be filled immediately (orders from us are usually filled several times a day, so there
may be a delay of a few hours).
Note that if you buy from the Mac App Store all subsequent updates must come from the Mac App Store
– you will not be able to use versions downloaded from the Sonny Software Web site.
I’d like to buy a license for the people in my group/department/institution. How much will it cost?
Licenses are available for groups of 5 ($225) and 10 ($325) users. The license belongs to the group and
not the individuals therein, so if anyone leaves the group they must buy their own license if they want to
continue using Bookends. If you need a license for more than 10 users, or a renewable site license for
large groups (50+), please contact Sales for pricing.
I own Bookends—where can I find my registration (serial) number so I can upgrade at the
discounted price?
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Your registration number was provided in the e-mail you received when you bought Bookends. If you
bought it from Sonny Software, the e-mail was sent from sales@sonnysoftware.com. If you bought the
Bookends/Mellel bundle, the e-mail was sent from redlex@redlers.com. If you can't find the e-mail,
contact sales@sonnysoftware.com with the name and address you used when you made the purchase
and we'll look it up for you.
What methods of payment are accepted?
Payment may be made by credit card (MasterCard or Visa), PayPal, check, or bank wire transfer. There is
no charge for the first three options, but there is a bank fee for a wire transfer that would be added to the
cost. You may use the order form on the Sonny Software web site for payment by credit card or PayPal.
Contact Sales for details on payment by check or bank wire transfer.
We can also prepare an invoice for organizations that must use a purchase order process. Contact Sales
for questions about purchase orders.
Can I install Bookends on both my desktop and laptop computers with one license?
Probably. Individual licenses are per user not per computer. That means if you are the only person using a
license, you can install it on more than one computer for your own use. Note that you can not run
Bookends on more than one computer simultaneously (a single user has no need for this). If more than
one person is using Bookends, you need one license for each person (or a group license).
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