FAQ

Why isn't scanning/inserting a citation in a Word document working?
Why do some graphics disappear after scanning a Word document?
Why am I having problems displaying and/or downloading pdfs?
Google Scholar searches and/or importing stopped working, what do I do?
I'm running macOS 10.15 or later and get an error when trying to open and convert an old
version of my library
Why am I frequently asked to re-sign in to iCloud with my Apple ID?
May I use Dropbox or equivalent to sync libraries?
I can't find the user Library folder. Where is it?
Where is my reference library on the hard drive?
Where is the User Guide? Where are the tutorials?
When I double click on the .dmg downloaded from Sonny Software, it doesn't open in the
Finder. Where is it?
Can I scan Word files that have EndNote citations?
How do I import references from other reference management apps?
Bookends isn’t working properly. What do I do?
How do I merge two libraries?
Why are text styles (i.e. italics, bold) not showing in my formatted references?
Why aren't PDFs added to the watch folder when Bookends isn't running imported?
How do I get a format or import filter to show up in the corresponding pop-up menus?
Where can I get a format for a particular source?
License/Purchase Information
I bought Bookends on the Mac App Store. I no longer see it there, how do I get it?
I bought a Lab/Small Workgroup license for Bookends 12. How do I upgrade to Bookends 13?
I own Bookends—where can I find my registration (serial) number?
Can I install Bookends on both my desktop and laptop computers with one license?
I have a question about my purchase from Fastspring, how do I conact them for an answer?
Why isn't scanning/inserting a citation in a Word document working?
Bookends exchanges information with Word via AppleEvents. There is a bug in Word that sometimes
causes it to stop responding to the "paste" AppleEvent, and after a scan or Copy Citation Word comes to
the front but the document's text is unchanged (although selected), and no bibliography was added. The
immediate solution is to perform a Paste (Command-V) yourself.
The longer term solution is to either relaunch Word (which sometimes works) or reboot your Mac (which
usually works). If those don't help, reinstalling Word seems to fix this issue.
Another possibility is that "Proofreading Scan" was checked in the scan dialog. Proofreading scans help
you manage temporary citations, they do not replace temporary citations with final citations, and will not
generate a bibliography. The User Guide has more information about Proofreading Scans.
If none of these solve the problem and the document contains numerous images, please see this
discussion of how to deal with very large Word documents.

Why do some graphics disappear after scanning a Word document?
There is a problem with some versions of Word that causes TIFF images to disappear after scanning with
Bookends. The solution is to save the images in another format (e.g. PNG or JPG) and use them to
replace the TIFFs. The PNG or JPG images will be retained after scanning.
Why am I having problems viewing and/or downloading pdfs?
Note: The following discussion applies only to versions of Bookends prior to 13.3.1 and to Reference
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Miner. Bookends Browser in version 13.3.1 or later is not aﬀected by these plug-ins.
You may have AdobePDFViewer and AdobePDFViewerNPAPI plug-ins installed. These plug-ins
interfere with Bookends' WebKit-based display of pdfs, such as in Autocomplete Paper. They will also
prevent you from importing pdfs by drag and drop of the pdf proxy icon in Bookends Browser and even
cause crashes.
You can tell that the Adobe PDF Viewer plugins are installed if the Bookends pdf display is solid black
or contains icons for functions such as printing. You may also see runtime error messages with comments
like "Condition: largestPixelSize.width > 0...".
Bookends 13.2.1 and later will alert you if these plug-ins are installed and oﬀer to remove them. You
should accept. Bookends will then move the plug-ins to the Trash.
If you are using an older version of Bookends, you can remove the plug-ins manually.

Go to this web page
https://helpx.adobe.com/acrobat/using/display-pdf-in-browser.html
and scroll down to the section on Safari and look for the heading
Disable AdobePDFViewer plug-in
and follow the instructions.

To summarize, remove the files
/Library/Internet Plug-ins/AdobePDFViewer.plugin
/Library/Internet Plug-ins/AdobePDFViewerNPAPI.plugin
Google Scholar searches and/or importing stopped working, what do I do?
Google Scholar uses a proprietary algorithm to detect activity coming from Web robots. If it suspects you
are a robot, searching and downloading metadata will be suspended. Note that the suspension is timelimited (approximately 24 hr). However, you can have your privileges restored more quickly if you take the
following steps. if you are using Bookends Online Search, a reCAPTCHA will usually appear in the lower
pane when you try to search Google Scholar. Once you have answered the questions correctly your
searching privileges should be restored. Restoration of importing privileges may take longer (up to 24 hr).
If you don't see a reCAPTCHA in the lower pane, i.e. searches fail silently, on the same machine go to
Google Scholar in a standalone browser and identify yourself as human.
I'm running macOS 10.15 or later and get an error when trying to open and convert an old version
of my library
A "-39" error means that macOS security features are blocking Bookends from updating the old library.
The solution is to go to System Preferences -> Privacy and give Bookends Full Disk Access.
Why am I frequently asked to re-sign in to iCloud with my Apple ID?
Cloud sync requires that you log in with your Apple ID. The re-sign in dialog put up by Apple no longer
oﬀers the option to stay signed in. If you are asked to re-sign in frequently (e.g. every day or two), do not
click "Continue with Password". Instead, click the Cancel button at the window's top right or "Use a
diﬀerent Apple ID”. A new sign in window with the "Keep me signed in" option will appear.
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May I use Dropbox or equivalent to sync libraries?
We strongly advise against using file sync services like Dropbox for Bookends libraries. If you use the
library on more than one machine it's easy to get "collisions" that can prevent file synchronization and
even cause corruption (this is probably the primary cause of damaged libraries that we see). Use
Bookends cloud sync instead. It's much faster, more robust, and can serve as a backup mechanism if the
library file itself becomes damaged.
Note that attachments (e.g. PDFs) should be synced with services like Dropbox. The corruption problem
only applies to libraries (databases).
I can't find the user Library folder. Where is it?
In macOS the user Library folder is hidden by default. To access it, hold down the Option key and use the
Finder menu Go -> Library. This will take you to
~/Library
and you can follow the trail to
~/Library/Application Support/Bookends/
A quick shortcut to the Bookends folder in Application Support is Help -> Show Bookends Folder in
Finder.
There you can access to various Bookends support files should you need them, such as your formats,
filters, and Bookends preferences.
Where is my reference library on the hard drive?
When you create a new library, it is given a name and saved to disk using the standard Save dialog. The
default location is in your user Library folder
~/Library/Application Support/Bookends/
Remember that you can access your Library folder by holding down the Option key and selecting the Go
menu in the Finder.
Note that you can always see the full path to your reference library by pressing the Command key and
clicking on the file proxy icon in the library window title bar.
You can also get to the Bookends folder via the Bookends Help menu: Show Bookends Folder in Finder
Where is the User Guide? Where are the tutorials?
The User Guide, tutorials (pdf and video), and Release Notes are available from the Bookends Help menu.
When I double click on the .dmg downloaded from Sonny Software, it doesn't open in the Finder.
Where is it?
The dmg may not open as a separate window. Instead, look for it in the Finder window, left pane, under
Devices.
Can I scan Word files that have EndNote citations?
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Usually. Follow these steps:
1) The key is to make sure that the EndNote record number in the citation matches the Bookends unique
ID for that reference. To do this, export your EndNote library as XML. Import this into a fresh Bookends
library and the EndNote record numbers will now be Bookends unique ID numbers.
2) Open your document in Microsoft Word and use the EndNote unformat command if the citations were
entered with Cite While You Write. All citations should now be visible in their temporary form (for example,
surrounded by curly brackets).
3) Scan the document with Bookends (make sure that the citation delimiters, such as curly brackets, as
set in Bookends Preferences are the same as those used by EndNote).
An alternative if you use references from PubMed is to create temporary citations as Author, Date, PMID
(an option introduced in Bookend 13.2). Such temporary citations will be recognized by both Bookends
and EndNote.
How do I import references from other reference management apps?
You can export and then import references, often with links to PDFs intact, from applications such as
EndNote, Papers, Sente, Zotero, and Mendeley. Here are specific instructions.
Bookends isn’t working properly. What do I do?
Damage to your Bookends library can have unpredictable results. If you are having problems that cannot
be reproduced in a fresh Bookends library, it is likely that this is the cause. In this case, the first thing you
should do is to rebuild the library (File -> Library Maintenance -> Rebuild). If the problem persists, try to
repair your database (File -> Library Maintenance > Repair). If the problem has still not been resolved,
contact us for technical support.
How do I merge two libraries?
There are two ways to do this: (1) Mark all your references, use File -> Export References (Hits) to export
them as a "Bookends" file, and then import this file into the destination library, or (2) drag the references
from one library window and drop them on another. If you think there may be duplicate references, after
the merge choose the menu item Refs -> Remove Duplicates.
Why are text styles (i.e. italics, bold) not showing in my formatted references?
Check Preferences -> Scan & Bib or Biblio -> Bibliography and make sure the output is set to Styled Text.
If it is, then check the bibliography font you are using (the default is in Preferences), and the font used in a
reference that is not displaying styled text. Not all fonts have an italic face (Lucida Grande, for example),
and in that case only plain text will be output.
Why aren't PDFs added to the watch folder when Bookends isn't running imported?
When a file is dropped into the watch folder, the Finder records the time and sends a notification to
Bookends. Sometimes the folder's metadata becomes corrupted and the time isn't saved so Bookends is
not notified when next launched. To correct this, create a new watch folder and point Bookends to it (File
-> Import From Watch Folder -> Configure). Add the PDFs to the new folder and they will be imported, as
will subsequently added PDFs, even if Bookends was not running when they were placed in the watch
folder.
How do I get a format or import filter to show up in the corresponding pop-up menus?
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You must enable the format or import filter by checking it in either the Formats Manager or the Import
Filters Manager, respectively.
Where can I get a format for a particular source?
You can create your own formats by selecting one in the Formats Manager that is similar to the one you
want and clicking on the Add button (use Biblio -> Create Format Catalog to see examples of all the
formats shipped with Bookends). Create an appropriate name for the new format and make whatever
changes are necessary. Details on format design are available in the User Guide. Alternatively, you can
ask other Bookends users if they have created such a format and will share it on the Bookends User
Forum. If you have altered a format we supply and want to obtain the original, you can download it from
our ftp site: ftp://ftp.sonnysoftware.com/pub/Formats/ (sign in as Guest).
License/Purchase Information
I bought Bookends on the Mac App Store. I no longer see it there, how do I get it?
As of version 13, Bookends is no longer for sale on the Mac App Store. You can upgrade to Bookends 13,
which is available on our web site. If you don't want to upgrade you can still download Bookends 12.8.4
by clicking the Purchased tab in the Mac App Store app.
I bought a Lab/Small Workgroup license for Bookends 12. How do I upgrade to Bookends 13?
Group incenses are no longer sold. You can, however, convert your old group licenses to the
corresponding number of individual licenses at a discount. To do this, write to Sonny Software
(sales@sonnysoftware.com) with your name and group license code and you will receive instructions on
how to proceed.
I own Bookends—where can I find my registration (serial) number?
Your registration number was provided in the e-mail you received when you bought Bookends. If you
bought it from Sonny Software, the e-mail was sent from sales@sonnysoftware.com. If you bought the
Bookends/Mellel bundle, the e-mail was sent from redlex@redlers.com. If you bought from the Mac App
Store you have no registration number. If you can't find the e-mail, contact sales@sonnysoftware.com
with the name and address you used when you made the purchase and we'll look it up for you.
Can I install Bookends on both my desktop and laptop computers with one license?
Probably. Licenses are per user, not per computer. That means if you are the only person using a license
you can install it on more than one computer for your own use. Note that you can not run Bookends on
more than one computer simultaneously (a single user has no need for this). If more than one person is
using Bookends, you need one license for each person.
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